]> git.pld-linux.org Git - packages/perl-Module-Pluggable-Ordered.git/commitdiff
- new auto/ac/perl-Module-Pluggable-Ordered-1_4-1
authorradek <radek@pld-linux.org>
Thu, 9 Dec 2004 12:19:09 +0000 (12:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-Module-Pluggable-Ordered.spec -> 1.1

perl-Module-Pluggable-Ordered.spec [new file with mode: 0644]

diff --git a/perl-Module-Pluggable-Ordered.spec b/perl-Module-Pluggable-Ordered.spec
new file mode 100644 (file)
index 0000000..2e6b9c4
--- /dev/null
@@ -0,0 +1,68 @@
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    Module
+%define        pnam    Pluggable-Ordered
+Summary:       Module::Pluggable::Ordered - Call module plugins in a specified order
+#Summary(pl):  
+Name:          perl-Module-Pluggable-Ordered
+Version:       1.4
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: a63e0c325b9690680d7ee6ac34e178d0
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-Module-Pluggable >= 1.9
+BuildRequires: perl-UNIVERSAL-exports
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module behaves exactly the same as C<Module::Pluggable>, supporting
+all of its options, but also mixes in the C<call_plugins> method to your
+class. C<call_plugins> acts a little like C<Class::Trigger>; it takes the
+name of a method, and some parameters. Let's say we call it like so:
+
+    __PACKAGE__->call_plugins("my_method", @something);
+
+C<call_plugins> looks at the plugin modules found using C<Module::Pluggable> 
+for ones which provide C<my_method_order>. It sorts the modules
+numerically based on the result of this method, and then calls
+C<$_-E<gt>my_method(@something)> on them in order. This produces an
+effect a little like the System V init process, where files can specify
+where in the init sequence they want to be called.
+
+# %description -l pl
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/Module/Pluggable/*.pm
+%{_mandir}/man3/*
This page took 0.121122 seconds and 4 git commands to generate.