]> git.pld-linux.org Git - packages/perl-Module-Install.git/blame - perl-Module-Install.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Install.git] / perl-Module-Install.spec
CommitLineData
9b82a0b9 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
9b82a0b9 5%define pdir Module
6%define pnam Install
7Summary: Module::Install - Standalone, extensible Perl module installer
6a4e84c6 8Summary(pl.UTF-8): Module::Install - samodzielny, rozszerzalny instalator modułów Perla
9b82a0b9 9Name: perl-Module-Install
b6fbd04d 10Version: 1.19
a3d3746c 11Release: 1
9b82a0b9 12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
68a7a578 15Source0: http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
b6fbd04d 16# Source0-md5: 0d1b78cc13ebf9b9ad008c8928a5b2dd
8876c945 17URL: http://search.cpan.org/dist/Module-Install/
9b82a0b9 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
89c3a0df 21BuildRequires: perl-Archive-Tar >= 1.44
22BuildRequires: perl-Devel-PPPort >= 3.16
68a7a578
JB
23BuildRequires: perl-ExtUtils-Install >= 1.52
24BuildRequires: perl-ExtUtils-MakeMaker >= 6.59
8237f529 25BuildRequires: perl-ExtUtils-ParseXS >= 2.19
89c3a0df 26BuildRequires: perl-File-Remove >= 1.42
68a7a578
JB
27BuildRequires: perl-JSON >= 2.14
28BuildRequires: perl-Module-Build >= 0.29
29BuildRequires: perl-Module-CoreList >= 2.17
46ee3bf7 30BuildRequires: perl-Module-ScanDeps >= 1.09
68a7a578 31BuildRequires: perl-PAR-Dist >= 0.29
46ee3bf7 32BuildRequires: perl-Parse-CPAN-Meta >= 1.4413
68a7a578 33BuildRequires: perl-PathTools >= 3.28
89c3a0df 34BuildRequires: perl-Test-Harness >= 3.13
35BuildRequires: perl-Test-Simple >= 0.86
36BuildRequires: perl-YAML-Tiny >= 1.38
68a7a578 37BuildRequires: perl-libwww >= 5.812
9b82a0b9 38%endif
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
9b82a0b9 42%description
43Module::Install is a package for writing installers for CPAN (or
44CPAN-like) distributions that are clean, simple, minimalist, act in a
45strictly correct manner with both the ExtUtils::MakeMaker and
46Module::Build build systems, and will run on any Perl installation
47version 5.004 or newer.
48
49The intent is to make it as easy as possible for CPAN authors (and
50especially for first-time CPAN authors) to have installers that follow
51all the best practices for distribution installation, but involve as
52much DWIM (Do What I Mean) as possible when writing them.
53
7f3505fe 54%description -l pl.UTF-8
8876c945 55Module::Install to pakiet do pisania dla dystrybucji CPAN (lub
7f3505fe
JR
56podobnych) instalatorów, które będą przejrzyste, minimalistyczne i
57działały całkowicie poprawnie z systemami budowania
58ExtUtils::MakeMaker i Module::Build, a także będą działać na każdej
8876c945
JB
59instalacji Perla od wersji 5.004.
60
7f3505fe
JR
61Celem jest jak największe ułatwienie autorom CPAN (a szczególnie
62początkującym autorom CPAN) posiadania instalatorów zachowujących się
8876c945 63jak najlepiej.
9b82a0b9 64
65%prep
66%setup -q -n %{pdir}-%{pnam}-%{version}
67
68%build
69%{__perl} Makefile.PL \
70 --skipdeps \
71 INSTALLDIRS=vendor
72%{__make}
73
74%{?with_tests:%{__make} test}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79%{__make} install \
80 DESTDIR=$RPM_BUILD_ROOT
81
68a7a578
JB
82%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Module/Install.pod
83
9b82a0b9 84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(644,root,root,755)
89%doc Changes README
68a7a578
JB
90%{perl_vendorlib}/Module/AutoInstall.pm
91%{perl_vendorlib}/Module/Install.pm
9b82a0b9 92%{perl_vendorlib}/Module/Install
68a7a578
JB
93%dir %{perl_vendorlib}/inc
94%dir %{perl_vendorlib}/inc/Module
95%{perl_vendorlib}/inc/Module/Install.pm
96%{perl_vendorlib}/inc/Module/Install
97%{_mandir}/man3/Module::AutoInstall.3pm*
98%{_mandir}/man3/Module::Install*.3pm*
99%{_mandir}/man3/inc::Module::Install*.3pm*
This page took 0.081368 seconds and 4 git commands to generate.