]> git.pld-linux.org Git - packages/perl-Module-Install.git/blob - perl-Module-Install.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Install.git] / perl-Module-Install.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Module
6 %define pnam    Install
7 Summary:        Module::Install - Standalone, extensible Perl module installer
8 Summary(pl.UTF-8):      Module::Install - samodzielny, rozszerzalny instalator modułów Perla
9 Name:           perl-Module-Install
10 Version:        1.19
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0d1b78cc13ebf9b9ad008c8928a5b2dd
17 URL:            http://search.cpan.org/dist/Module-Install/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Archive-Tar >= 1.44
22 BuildRequires:  perl-Devel-PPPort >= 3.16
23 BuildRequires:  perl-ExtUtils-Install >= 1.52
24 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
25 BuildRequires:  perl-ExtUtils-ParseXS >= 2.19
26 BuildRequires:  perl-File-Remove >= 1.42
27 BuildRequires:  perl-JSON >= 2.14
28 BuildRequires:  perl-Module-Build >= 0.29
29 BuildRequires:  perl-Module-CoreList >= 2.17
30 BuildRequires:  perl-Module-ScanDeps >= 1.09
31 BuildRequires:  perl-PAR-Dist >= 0.29
32 BuildRequires:  perl-Parse-CPAN-Meta >= 1.4413
33 BuildRequires:  perl-PathTools >= 3.28
34 BuildRequires:  perl-Test-Harness >= 3.13
35 BuildRequires:  perl-Test-Simple >= 0.86
36 BuildRequires:  perl-YAML-Tiny >= 1.38
37 BuildRequires:  perl-libwww >= 5.812
38 %endif
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Module::Install is a package for writing installers for CPAN (or
44 CPAN-like) distributions that are clean, simple, minimalist, act in a
45 strictly correct manner with both the ExtUtils::MakeMaker and
46 Module::Build build systems, and will run on any Perl installation
47 version 5.004 or newer.
48
49 The intent is to make it as easy as possible for CPAN authors (and
50 especially for first-time CPAN authors) to have installers that follow
51 all the best practices for distribution installation, but involve as
52 much DWIM (Do What I Mean) as possible when writing them.
53
54 %description -l pl.UTF-8
55 Module::Install to pakiet do pisania dla dystrybucji CPAN (lub
56 podobnych) instalatorów, które będą przejrzyste, minimalistyczne i
57 działały całkowicie poprawnie z systemami budowania
58 ExtUtils::MakeMaker i Module::Build, a także będą działać na każdej
59 instalacji Perla od wersji 5.004.
60
61 Celem jest jak największe ułatwienie autorom CPAN (a szczególnie
62 początkującym autorom CPAN) posiadania instalatorów zachowujących się
63 jak najlepiej.
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67
68 %build
69 %{__perl} Makefile.PL \
70         --skipdeps \
71         INSTALLDIRS=vendor
72 %{__make}
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Module/Install.pod
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changes README
90 %{perl_vendorlib}/Module/AutoInstall.pm
91 %{perl_vendorlib}/Module/Install.pm
92 %{perl_vendorlib}/Module/Install
93 %dir %{perl_vendorlib}/inc
94 %dir %{perl_vendorlib}/inc/Module
95 %{perl_vendorlib}/inc/Module/Install.pm
96 %{perl_vendorlib}/inc/Module/Install
97 %{_mandir}/man3/Module::AutoInstall.3pm*
98 %{_mandir}/man3/Module::Install*.3pm*
99 %{_mandir}/man3/inc::Module::Install*.3pm*
This page took 0.060527 seconds and 4 git commands to generate.