]> git.pld-linux.org Git - packages/perl-Module-Build-Tiny.git/blob - perl-Module-Build-Tiny.spec
23751635728df75ecce58d50aa45fc7dbfcb0fd7
[packages/perl-Module-Build-Tiny.git] / perl-Module-Build-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build-Tiny
7 Summary:        Module::Build::Tiny - A tiny replacement for Module::Build
8 Summary(pl.UTF-8):      Module::Build::Tiny - mały zamiennik systemu Module::Build
9 Name:           perl-Module-Build-Tiny
10 Version:        0.039
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2332c90c17454107fea3f2614e11a3a9
17 URL:            http://search.cpan.org/dist/Module-Build-Tiny/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-ExtUtils-Config >= 0.003
23 BuildRequires:  perl-ExtUtils-Helpers >= 0.020
24 BuildRequires:  perl-ExtUtils-InstallPaths >= 0.002
25 BuildRequires:  perl-Test-Harness >= 3.30
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Many Perl distributions use a Build.PL file instead of a Makefile.PL
32 file to drive distribution configuration, build, test and
33 installation. Traditionally, Build.PL uses Module::Build as
34 the underlying build system. This module provides a simple,
35 lightweight, drop-in replacement.
36
37 Whereas Module::Build has over 6,700 lines of code; this module has
38 less than 120, yet supports the features needed by most distributions.
39
40 %description -l pl.UTF-8
41 Wiele pakietów perlowych wykorzystuje plik Build.PL zamiast pliku
42 Makefile.PL do sterowania konfiguracją, budowaniem, testowaniem i
43 instajacją. Tradycyjnie Build.PL w roli systemu budującego
44 wykorzystuje Module::Build; ten moduł dostarcza prosty, lekki
45 zamiennik.
46
47 O ile Module::Build ma ponad 6700 linii kodu, ten moduł ma mniej niż
48 120, a obsługuje funkcje wymaganych przez większość pakietów.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %{__sed} -i -e 's/.*in blib is readonly.*/#&/g' t/simple.t
54
55 %build
56 %{__perl} Build.PL \
57         --installdirs=vendor
58 ./Build
59
60 %{?with_tests:./Build test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 ./Build install \
66         --destdir=$RPM_BUILD_ROOT \
67         --create_packlist=0
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes INSTALL README
75 %dir %{perl_vendorlib}/Module/Build
76 %{perl_vendorlib}/Module/Build/Tiny.pm
77 %{_mandir}/man3/Module::Build::Tiny.3pm*
This page took 0.298968 seconds and 2 git commands to generate.