]> git.pld-linux.org Git - packages/perl-Math-Vec.git/blob - perl-Math-Vec.spec
- updated to 1.01
[packages/perl-Math-Vec.git] / perl-Math-Vec.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    Vec
8 Summary:        Math::Vec - Object-Oriented Vector Math Methods in Perl
9 Summary(pl.UTF-8):      Math::Vec - zorientowane obiektowo metody do wektorów w Perlu
10 Name:           perl-Math-Vec
11 Version:        1.01
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3d881e6f8074257d54125190719859eb
18 URL:            http://search.cpan.org/dist/Math-Vec/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module was adapted from Math::Vector, written by Wayne M.
27 Syvinski.
28
29 It uses most of the same algorithms, and currently preserves the same
30 names as the original functions, though some aliases have been added
31 to make the interface more natural (at least to the way I think.)
32
33 The "object" for the object oriented calling style is a blessed array
34 reference which contains a vector of the form [x,y,z]. Methods will
35 typically return a list.
36
37 %description -l pl.UTF-8
38 Ten moduł został zaadaptowany z Math::Vector napisanego przez Wayne'a
39 M. Syvinskiego.
40
41 Używa w większości tych samych algorytmów i aktualnie zachowuje te
42 same nazwy jak funkcje oryginalne, ale dodano trochę aliasów, aby
43 uczynić interfejs bardziej naturalnym (przynajmniej zdaniem autora).
44
45 "Obiekt" dla zorientowanego obiektowo stylu wywołań jest
46 pobłogosławioną referencją do tablicy zawierającą wektor w postaci
47 [x,y,z]. Metody zwykle zwracają listę.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor \
55         destdir=$RPM_BUILD_ROOT
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README
71 %{perl_vendorlib}/Math/Vec.pm
72 %{_mandir}/man3/*
This page took 0.153585 seconds and 3 git commands to generate.