]> git.pld-linux.org Git - packages/perl-Math-Random.git/blob - perl-Math-Random.spec
perl 5.38.0 rebuild
[packages/perl-Math-Random.git] / perl-Math-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    Random
7 Summary:        Math::Random - random number generators
8 Summary(pl.UTF-8):      Math::Random - generatory liczb losowych
9 Name:           perl-Math-Random
10 Version:        0.71
11 Release:        16
12 # same as perl except some C code
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  55d7579c670ecd180f71fd157a2d2070
17 URL:            http://search.cpan.org/dist/Math-Random/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Math::Random is a Perl port of the C version of randlib, which is
24 a suite of routines for generating random deviates.
25
26 %description -l pl.UTF-8
27 Math::Random jest perlowym portem napisanej w C biblioteki randlib,
28 będącej zbiorem procedur do generowania liczb losowych.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32 mkdir examples
33 mv example.pl examples
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT \
47         INSTALLDIRS=vendor
48
49 install -d $RPM_BUILD_ROOT%{_examplesdir}
50 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README MANIFEST
58 %{perl_vendorarch}/Math/*.pm
59 %dir %{perl_vendorarch}/auto/Math/Random
60 %attr(755,root,root) %{perl_vendorarch}/auto/Math/Random/*.so
61 %{perl_vendorarch}/auto/Math/Random/*.ix
62 %dir %{_examplesdir}/%{name}-%{version}
63 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
64 %{_mandir}/man3/*
This page took 0.424228 seconds and 3 git commands to generate.