]> git.pld-linux.org Git - packages/perl-Math-Prime-XS.git/blob - perl-Math-Prime-XS.spec
- perl req/prov fix
[packages/perl-Math-Prime-XS.git] / perl-Math-Prime-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define pdir    Math
7 %define pnam    Prime-XS
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Math::Prime::XS - Calculate/detect prime numbers with deterministic tests
10 Name:           perl-Math-Prime-XS
11 Version:        0.26_01
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b93a438fd10640b47910be8f9c3403ba
18 URL:            http://search.cpan.org/dist/Math-Prime-XS/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-boolean
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Math::Prime::XS calculates/detects prime numbers by either applying
28 Modulo operator division, the Sieve of Eratosthenes, Trial division or
29 a Summing calculation.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35         #config="optimize='%{rpmcflags}'" \
36 %{__perl} Build.PL \
37         destdir=$RPM_BUILD_ROOT \
38         installdirs=vendor
39 ./Build
40
41 %{?with_tests:./Build test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 ./Build install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes INSTALL README
54 %dir %{perl_vendorarch}/Math/Prime
55 %{perl_vendorarch}/Math/Prime/XS.pm
56 %dir %{perl_vendorarch}/auto/Math/Prime
57 %dir %{perl_vendorarch}/auto/Math/Prime/XS
58 %attr(755,root,root) %{perl_vendorarch}/auto/Math/Prime/XS/*.so
59 %{_mandir}/man3/*
This page took 0.578501 seconds and 4 git commands to generate.