]> git.pld-linux.org Git - packages/perl-Math-PRSG.git/blob - perl-Math-PRSG.spec
65219d2ec88854168d6e530a27aa55e8f612b18f
[packages/perl-Math-PRSG.git] / perl-Math-PRSG.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    PRSG
8 Summary:        Math::PRSG perl module
9 Summary(pl.UTF-8):      ModuĊ‚ perla Math::PRSG
10 Name:           perl-Math-PRSG
11 Version:        1.0
12 Release:        9
13 # if used in a product, Systemics should be given attribution as the author
14 License:        free use, distributable
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4f0c32973d5b03d2a665b6ac6ec04b9c
18 Patch0:         %{name}-paths.patch
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::PRSG - interface to pseudo random sequence generator function.
25
26 %description -l pl.UTF-8
27 Math::PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31 %patch0 -p1
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make} \
37         CC="%{__cc}" \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc examples/prsg_driver.pl
54 %{perl_vendorarch}/Math/PRSG.pm
55 %dir %{perl_vendorarch}/auto/Math/PRSG
56 %{perl_vendorarch}/auto/Math/PRSG/PRSG.bs
57 %attr(755,root,root) %{perl_vendorarch}/auto/Math/PRSG/PRSG.so
58 %{_mandir}/man3/*
This page took 0.095169 seconds and 2 git commands to generate.