]> git.pld-linux.org Git - packages/perl-Math-MatrixReal.git/blob - perl-Math-MatrixReal.spec
- tabs in preamble
[packages/perl-Math-MatrixReal.git] / perl-Math-MatrixReal.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    MatrixReal
8 Summary:        Math::MatrixReal - implements the data type "matrix of reals"
9 Summary(pl.UTF-8):      Math::MatrixReal - implementacja typu danych "macierz liczb rzeczywistych"
10 Name:           perl-Math-MatrixReal
11 Version:        1.9
12 Release:        6
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4df6e63d0e9ff902f1af5dc430a0b483
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Implements the data type "matrix of reals" (and consequently also
25 "vector of reals"), which can be used almost like any other basic Perl
26 type thanks to OPERATOR OVERLOADING, i.e., "$product = $matrix1 *
27 $matrix2;" does what you would like it to do (a matrix
28 multiplication).
29
30 %description -l pl.UTF-8
31 Ten moduł jest implementacją typu danych "macierz liczb rzeczywistych"
32 (i w konsekwencji także "wektor liczb rzeczywistych"), który może być
33 używany prawie tak samo jak każdy inny podstawowy typ Perla dzięki
34 przeciążaniu operatorów - tzn. "$product = $matrix1 * $matrix2;" zrobi
35 to, czego się oczekuje (pomnoży macierze).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 # get rid of pod documentation
54 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Math/*.pod
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %{perl_vendorlib}/Math/*
63 %{_mandir}/man3/*
This page took 0.056671 seconds and 3 git commands to generate.