]> git.pld-linux.org Git - packages/perl-Math-GSL.git/blob - perl-Math-GSL.spec
perl 5.38.0 rebuild
[packages/perl-Math-GSL.git] / perl-Math-GSL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    GSL
7 Summary:        Math::GSL Perl module - resticted interface to GNU Scientific Library
8 Summary(pl.UTF-8):      Moduł Perla Math::GSL - ograniczony interfejs do GNU Scientific Library
9 Name:           perl-Math-GSL
10 Version:        0.43
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8db782c053ec8417f39f55439a65d3c5
17 Patch0:         gsl-2.7.1.patch
18 URL:            https://search.cpan.org/dist/Math-GSL/
19 BuildRequires:  gsl-devel >= 1.15
20 BuildRequires:  perl-Alien-GSL
21 BuildRequires:  perl-Module-Build >= 0.38
22 BuildRequires:  perl-PkgConfig >= 0.07720
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  swig-perl
26 %if %{with tests}
27 BuildRequires:  perl-Test-Class >= 0.12
28 BuildRequires:  perl-Test-Deep
29 BuildRequires:  perl-Test-Differences
30 BuildRequires:  perl-Test-Exception >= 0.21
31 BuildRequires:  perl-Test-Most >= 0.31
32 BuildRequires:  perl-Test-Taint >= 1.06
33 BuildRequires:  perl-Test-Warn
34 BuildRequires:  perl-version >= 0.77
35 %endif
36 Requires:       gsl >= 1.15
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Math::GSL Perl module is a very resticted perl interface to -lgsl -
41 GNU Scientific Library. Only the routines relating the solving of
42 polynomials are exported. It exists to provide that function to
43 "tkscope" in Audio::Data.
44
45 %description -l pl.UTF-8
46 Moduł Perla Math::GSL stanowi bardzo ograniczony interfejs do -lgsl -
47 Biblioteki Naukowej GNU (GNU Scientific Library). Eksportuje jedynie
48 funkcje dotyczące rozwiązywania równań wielomianowych. Istnieje, aby
49 udostępnić te funkcje "tkscope" w module Audio::Data.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p1
54
55 # simulate non-release to force swig rebuild
56 mkdir .git
57
58 %build
59 export CC_FLAGS="%{rpmcppflags} %{rpmcflags}"
60 %{__perl} Build.PL \
61         destdir=$RPM_BUILD_ROOT \
62         installdirs=vendor
63 ./Build
64
65 %{?with_tests:./Build test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 ./Build install
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc CREDITS Changes KNOWN_BUGS README.md TODO
78 %{perl_vendorarch}/Math/GSL.pm
79 %{perl_vendorarch}/Math/GSL
80 %dir %{perl_vendorarch}/auto/Math/GSL
81 %dir %{perl_vendorarch}/auto/Math/GSL/*
82 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GSL/*/*.so
83 %{_mandir}/man3/Math::GSL*.3pm*
This page took 0.139606 seconds and 4 git commands to generate.