]> git.pld-linux.org Git - packages/perl-Math-FFT.git/blob - perl-Math-FFT.spec
perl 5.38.0 rebuild
[packages/perl-Math-FFT.git] / perl-Math-FFT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    FFT
7 Summary:        Math::FFT - Perl module to calculate Fast Fourier Transforms
8 Summary(pl.UTF-8):      Math::FFT - moduł Perla do obliczania szybkiej transformaty Fouriera
9 Name:           perl-Math-FFT
10 Version:        1.31
11 Release:        11
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  531cf2c2ea45d01e414fe75aac0a2c1e
17 URL:            http://search.cpan.org/dist/Math-FFT/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements some algorithms for calculating Fast Fourier
24 Transforms for one-dimensional data sets of size 2^n.
25
26 %description -l pl.UTF-8
27 Ten moduł zawiera implementacje algorytmów do obliczania szybkiej
28 transformaty Fouriera dla jednowymiarowych zbiorów danych rozmiaru
29 2^n.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/Math/FFT.pm
57 %dir %{perl_vendorarch}/auto/Math/FFT
58 %attr(755,root,root) %{perl_vendorarch}/auto/Math/FFT/FFT.so
59 %{_mandir}/man3/*
This page took 0.108334 seconds and 4 git commands to generate.