]> git.pld-linux.org Git - packages/perl-Math-ConvexHull.git/blob - perl-Math-ConvexHull.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-ConvexHull.git] / perl-Math-ConvexHull.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    ConvexHull
7 Summary:        Math::ConvexHull - Calculate convex hulls using Graham's scan (n*log(n))
8 Name:           perl-Math-ConvexHull
9 Version:        1.04
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  5d9225c5fadf5c71172cd88c81661d4d
16 URL:            http://search.cpan.org/dist/Math-ConvexHull/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Math::ConvexHull is a simple module that calculates convex hulls from a set
24 of points in 2D space. It is a straightforward implementation of the algorithm
25 known as Graham's scan which, with complexity of O(n*log(n)), is the fastest
26 known method of finding the convex hull of an arbitrary set of points.
27 There are some methods of eliminating points that cannot be part of the
28 convex hull. These may or may not be implemented in a future version.
29
30 The implementation cannot deal with duplicate points. Therefore, points
31 which are very, very close (think floating point close) to the
32 previous point are dropped since version 1.02 of the module.
33 However, if you pass in randomly ordered data which contains duplicate points,
34 this safety measure might not help you. In that case, you will have to
35 remove duplicates yourself.
36
37 None by default, but you may choose to have the convex_hull() subroutine
38 exported to your namespace using standard Exporter semantics.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Math/*.pm
63 %{_mandir}/man3/*
This page took 0.062501 seconds and 4 git commands to generate.