]> git.pld-linux.org Git - packages/perl-Math-ConvexHull-MonotoneChain.git/blob - perl-Math-ConvexHull-MonotoneChain.spec
perl 5.38.0 rebuild
[packages/perl-Math-ConvexHull-MonotoneChain.git] / perl-Math-ConvexHull-MonotoneChain.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    ConvexHull-MonotoneChain
7 Summary:        Math::ConvexHull::MonotoneChain - Andrew's monotone chain algorithm for finding a convex hull in 2D
8 Name:           perl-Math-ConvexHull-MonotoneChain
9 Version:        0.01
10 Release:        11
11 License:        Perl
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  eaac1a9350f914fea5bbce2029b95b57
15 URL:            http://search.cpan.org/dist/Math-ConvexHull-MonotoneChain/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is somewhat experimental still.
22
23 This (XS) module optionally exports a single function convex_hull
24 which calculates the convex hull of the input points and returns it.
25 The algorithm is O(n log n) due to having to sort the input list, but
26 should be somewhat faster than a plain Graham's scan (also O(n log n))
27 in practice since it avoids polar coordinates.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         CC="%{__cc}" \
37         OPTIMIZE="%{rpmcflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes
53 %dir %{perl_vendorarch}/Math/ConvexHull
54 %{perl_vendorarch}/Math/ConvexHull/MonotoneChain.pm
55 %dir %{perl_vendorarch}/auto/Math/ConvexHull
56 %dir %{perl_vendorarch}/auto/Math/ConvexHull/MonotoneChain
57 %attr(755,root,root) %{perl_vendorarch}/auto/Math/ConvexHull/MonotoneChain/MonotoneChain.so
58 %{_mandir}/man3/*
This page took 0.159653 seconds and 4 git commands to generate.