]> git.pld-linux.org Git - packages/perl-Math-Base36.git/blob - perl-Math-Base36.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-Base36.git] / perl-Math-Base36.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    Base36
7 Summary:        Math::Base36 Perl module - encoding and decoding of base36 strings
8 Summary(pl.UTF-8):      Moduł Perla Math::Base36 - kodowanie i dekodowanie łańcuchów base36
9 Name:           perl-Math-Base36
10 Version:        0.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3af1a961e45c0e367e78685a518f5dde
17 URL:            http://search.cpan.org/dist/Math-Base36/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module converts to and from Base36 numbers (0..9 - A..Z).
25
26 %description -l pl.UTF-8
27 Ten moduł konwertuje do i z liczb Base36 (w systemie o podstawie 36 -
28 z cyframi 0..9,A..Z).
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes
52 %{perl_vendorlib}/Math/Base36.pm
53 %{_mandir}/man3/*
This page took 0.144647 seconds and 4 git commands to generate.