]> git.pld-linux.org Git - packages/perl-Makefile-DOM.git/blob - perl-Makefile-DOM.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Makefile-DOM.git] / perl-Makefile-DOM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Makefile
6 %define         pnam    DOM
7 Summary:        Makefile::DOM - Simple DOM parser for Makefiles
8 Summary(pl.UTF-8):      Makefile::DOM - prosty analizator DOM dla plików Makefile
9 Name:           perl-Makefile-DOM
10 Version:        0.006
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AG/AGENT/Makefile-DOM-%{version}.tar.gz
16 # Source0-md5:  c9136d35514d3445288d5f4b8cea5703
17 URL:            http://search.cpan.org/dist/Makefile-DOM/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Clone >= 0.18
23 BuildRequires:  perl-List-MoreUtils >= 0.21
24 BuildRequires:  perl-Params-Util >= 0.22
25 %endif
26 Requires:       perl-Clone >= 0.18
27 Requires:       perl-List-MoreUtils >= 0.21
28 Requires:       perl-Params-Util >= 0.22
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This library can serve as an advanced lexer for (GNU) makefiles. It
34 parses makefiles as "documents" and the parsing is lossless. The
35 results are data structures similar to DOM trees. The DOM trees hold
36 every single bit of the information in the original input files,
37 including white spaces, blank lines and makefile comments. That means
38 it's possible to reproduce the original makefiles from the DOM trees.
39 In addition, each node of the DOM trees is modifiable and so is the
40 whole tree, just like the PPI module used for Perl source parsing and
41 the HTML::TreeBuilder module used for parsing HTML source.
42
43 %description -l pl.UTF-8
44 Ta biblioteka może służyć jako zaawansowany analizator leksykalny dla
45 plików (GNU) Makefile. Analizuje pliki Makefile jako "dokumenty" w
46 sposób bezstratny. Wynikiem są struktury danych podobne do drzew DOM.
47 Drzewa DOM przechowują każdy fragment informacji z oryginalnych plików
48 wejściowych, wraz z odstępami, pustymi liniami i komentarzami. Oznacza
49 to, że z drzew DOM można odtworzyć oryginalne pliki Makefile. Ponadto
50 każdy węzeł w drzewie DOM może być modyfikowany, podobnie jak całe
51 drzewo, podobnie jak w przypadku modułu PPI przy analizie źródeł
52 perlowych czy modułu HTML::TreeBuilder przy analizie źródeł HTML.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 # fails
58 %{__rm} t/pod-coverage.t
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} pure_install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes TODO
79 %{perl_vendorlib}/MDOM
80 %dir %{perl_vendorlib}/Makefile
81 %{perl_vendorlib}/Makefile/DOM.pm
82 %{_mandir}/man3/MDOM*.3pm*
83 %{_mandir}/man3/Makefile::DOM.3pm*
This page took 0.063955 seconds and 4 git commands to generate.