]> git.pld-linux.org Git - packages/perl-Mail-RFC822-Address.git/blob - perl-Mail-RFC822-Address.spec
use generic url
[packages/perl-Mail-RFC822-Address.git] / perl-Mail-RFC822-Address.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Mail
6 %define         pnam    RFC822-Address
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mail::RFC822::Address - validating email addresses according to RFC822
9 Summary(pl.UTF-8):      Mail::RFC822::Address - sprawdzanie poprawności adresów e-mail wg RFC822
10 Name:           perl-Mail-RFC822-Address
11 Version:        0.3
12 Release:        2
13 License:        BSD-like
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0bd88b2ffedd95a4a920053fd6d0b709
17 URL:            http://search.cpan.org/dist/Mail-RFC822-Address/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Mail::RFC822::Address validates email addresses against the grammar
25 described in RFC 822 using regular expressions. How to validate a user
26 supplied email address is a FAQ (see perlfaq9): the only sure way to
27 see if a supplied email address is genuine is to send an email to it
28 and see if the user recieves it. The one useful check that can be
29 performed on an address is to check that the email address is
30 syntactically valid. That is what this module does.
31
32 This module is functionally equivalent to RFC::RFC822::Address, but
33 uses regular expressions rather than the Parse::RecDescent parser.
34 This means that startup time is greatly reduced making it suitable for
35 use in transient scripts such as CGI scripts.
36
37 %description -l pl.UTF-8
38 Mail::RFC822::Address sprawdza poprawność adresów e-mail wg gramatyki
39 opisanej w RFC 822 przy użyciu wyrażeń regularnych. Sposób sprawdzenia
40 poprawności adresu e-mail podanego przez użytkownika jest w FAQ
41 (perlfaq9): jedynym sposobem sprawdzenia, czy podany adres jest
42 prawdziwy jest wysłanie na niego wiadomości i sprawdzenie, czy
43 użytkownik ją otrzyma. Jedyny użyteczny test który można wykonać na
44 adresie to sprawdzenie, czy adres jest poprawny syntaktycznie - i to
45 właśnie robi moduł.
46
47 Ten moduł jest funkcjonalnie równoważny RFC::RFC822::Address, ale
48 używa wyrażeń regularnych zamiast analizatora Parse::RecDescent.
49 Oznacza to znaczne zmniejszenie czasu ładowania, co czyni moduł
50 przydatnym do używania w skryptach np. CGI.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes
75 %{perl_vendorlib}/Mail/RFC822
76 %{_mandir}/man3/*
This page took 0.102984 seconds and 4 git commands to generate.