]> git.pld-linux.org Git - packages/perl-Mail-Message.git/blob - perl-Mail-Message.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-Message.git] / perl-Mail-Message.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    Message
7 Summary:        Mail::Message - general message object
8 Name:           perl-Mail-Message
9 Version:        3.008
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        https://cpan.metacpan.org/authors/id/M/MA/MARKOV/Mail-Message-%{version}.tar.gz
15 # Source0-md5:  cac8626437d21b645e94c4d949f43545
16 #URL:           https://metacpan.org/release/Mail-Message/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(User::Identity) >= 0.94
21 BuildRequires:  perl-IO-stringy
22 BuildRequires:  perl-MIME-Types >= 1.004
23 BuildRequires:  perl-Mail-Box
24 BuildRequires:  perl-MailTools >= 2.17
25 BuildRequires:  perl-TimeDate
26 BuildRequires:  perl-URI >= 1.23
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A Mail::Message object is a container for MIME-encoded message
33 information, as defined by RFC2822. Everything what is not specificaly
34 related to storing the messages in mailboxes (folders) is implemented
35 in this class. Methods which are related to folders is implemented in
36 the Mail::Box::Message extension.
37
38 The main methods are get(), to get information from a message header
39 field, and decoded() to get the intended content of a message. But
40 there are many more which can assist your program.
41
42 Complex message handling, like construction of replies and forwards,
43 are implemented in separate packages which are autoloaded into this
44 class. This means you can simply use these methods as if they are part
45 of this class. Those package add functionality to all kinds of message
46 objects.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README
70 %{perl_vendorlib}/Mail/*.pm
71 %{perl_vendorlib}/Mail/Box/*
72 %{perl_vendorlib}/Mail/Message
73 %{perl_vendorlib}/Mail/*.pod
74 %{_mandir}/man3/*
This page took 0.220942 seconds and 4 git commands to generate.