]> git.pld-linux.org Git - packages/perl-Mail-DomainKeys.git/blob - perl-Mail-DomainKeys.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-DomainKeys.git] / perl-Mail-DomainKeys.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    DomainKeys
7 Summary:        Mail::Alias - implementation of Yahoo's mail signature protocol
8 Summary(pl.UTF-8):      Mail::Alias - implementacja protokołu sygnatur pocztowych Yahoo
9 Name:           perl-Mail-DomainKeys
10 Version:        1.0
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a4565f21ada263cf34c55f50d7eb9944
17 Patch0:         %{name}-notconnected.patch
18 URL:            http://search.cpan.org/dist/Mail-DomainKeys/
19 BuildRequires:  perl-Crypt-OpenSSL-RSA
20 BuildRequires:  perl-MIME-Base64
21 #BuildRequires: perl-Mail-Address
22 BuildRequires:  perl-Net-DNS >= 0.34
23 #BuildRequires: perl-Test-More
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Mail::DomainKeys is a perl implementation of Yahoo's mail signature
31 protocol.
32
33 This library allows one to sign and verify signatures as per per draft
34 03 of the DomainKeys specification:
35
36 http://www.ietf.org/internet-drafts/draft-delany-domainkeys-base-03.txt
37
38 %description -l pl.UTF-8
39 Mail::DomainKeys jest implementacją protokołu sygnatur pocztowych Yahoo.
40
41 Ta biblioteka umożliwia sygnowanie i weryfikacje sygnatur zgodnie z
42 draftem 03 specyfikacji DomainKeys:
43
44 http://www.ietf.org/internet-drafts/draft-delany-domainkeys-base-03.txt
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp t/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README
72 %dir %{perl_vendorlib}/Mail/DomainKeys
73 %dir %{perl_vendorlib}/Mail/DomainKeys/Key
74 %{perl_vendorlib}/Mail/DomainKeys.pm
75 %{perl_vendorlib}/Mail/DomainKeys/*.pm
76 %{perl_vendorlib}/Mail/DomainKeys/Key/*.pm
77 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
78 %{_mandir}/man3/*
This page took 0.115949 seconds and 4 git commands to generate.