]> git.pld-linux.org Git - packages/perl-Mail-Box.git/blob - perl-Mail-Box.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Mail-Box.git] / perl-Mail-Box.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    Mail
6 %define         pnam    Box
7 Summary:        Mail::Box - manage a mailbox, a folder with messages
8 Summary(pl.UTF-8):      Mail::Box - zarządzanie skrzynką, folderem z wiadomościami
9 Name:           perl-Mail-Box
10 Version:        3.008
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f29b1eb53b2550fc22e89762a8bb5630
16 URL:            http://search.cpan.org/dist/Mail-Box/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Encode) >= 1.86
21 BuildRequires:  perl(Scalar::Util) >= 1.07
22 BuildRequires:  perl-Devel-GlobalDestruction >= 0.09a3
23 BuildRequires:  perl-File-Remove >= 0.2
24 BuildRequires:  perl-HTML-Format
25 BuildRequires:  perl-IO-stringy
26 BuildRequires:  perl-MIME-Types >= 1.004
27 BuildRequires:  perl-Mail-SpamAssassin
28 BuildRequires:  perl-Object-Realize-Later >= 0.19
29 BuildRequires:  perl-Test-Simple >= 0.47
30 BuildRequires:  perl-Text-Autoformat
31 BuildRequires:  perl-TimeDate
32 BuildRequires:  perl-User-Identity
33 BuildRequires:  perl-base
34 %endif
35 # not found by perl.req
36 Requires:       perl-Object-Realize-Later >= 0.19
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define _noautoreq      'perl(Mail::SpamAssassin)' 'perl(Text::Autoformat)' 'perl(HTML::FormatText)' 'perl(Mail::Transport::Dbx).*'
41
42 %description
43 The Mail::Box folder is a modern mail-folder manager -- at least at
44 the moment of this writing ;) It is written to replace Mail::Folder,
45 although it interface is different.
46
47 %description -l pl.UTF-8
48 Folder Mail::Box to współczesny zarządca folderów pocztowych -
49 przynajmniej w chwili pisania ;). Jest pisany, aby zastąpić
50 Mail::Folder, aczkolwiek interfejs jest inny.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor \
58         < /dev/null
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68 find $RPM_BUILD_ROOT -type f -name '*.pod' -exec rm -f '{}' \;
69
70 install -d $RPM_BUILD_ROOT%{_examplesdir}
71 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ChangeLog README*
79 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
80 %{perl_vendorlib}/Mail/*
81 %{_mandir}/man3/*
This page took 0.136865 seconds and 4 git commands to generate.