]> git.pld-linux.org Git - packages/perl-MIME-Types.git/blob - perl-MIME-Types.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MIME-Types.git] / perl-MIME-Types.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    MIME
6 %define         pnam    Types
7 Summary:        MIME::Types Perl module - definition of MIME types
8 Summary(pl.UTF-8):      Moduł Perla MIME::Types - definicje typów MIME
9 Name:           perl-MIME-Types
10 Version:        2.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MIME/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6f1441addab947137bac92c379a47ba3
17 URL:            http://search.cpan.org/dist/MIME-Types/
18 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.47}
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  perl-libnet
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 MIME types are used in MIME compliant lines, for instance as part of
27 e-mail and HTTP traffic, to indicate the type of content which is
28 transmitted. Sometimes real knowledge about a mime-type is need.
29
30 This module maintains a set of MIME::Type objects, which each describe
31 one known MIME type. There are many types defined by RFCs and vendors,
32 so the list is long but not complete.
33  
34 %description -l pl.UTF-8
35 Typy MIME są używane w liniach nagłówka zgodnych z MIME, na przykład
36 jako część transmisji e-mail lub HTTP, do określenia rodzaju
37 przesyłanej treści. Czasem potrzebna jest znajomość prawdziwego
38 mime-type.
39
40 Ten moduł utrzymuje zbiór obiektów MIME::Type, z których każdy opisuje
41 jeden znany typ MIME. Zawiera wiele typów zdefiniowanych przez RFC i
42 producentów, więc lista jest długa, ale niepełna.
43
44 %package -n perl-MojoX-MIME-Types
45 Summary:        MojoX::MIME::Types - MIME Types for Mojolicious
46 Summary(pl.UTF-8):      MojoX::MIME::Types - typy MIME dla szkieletu Mojolicious
47 Group:          Development/Languages/Perl
48 Requires:       %{name} = %{version}-%{release}
49
50 %description -n perl-MojoX-MIME-Types
51 This module is a drop-in replacement for Mojolicious::Types, but with
52 a more correct handling plus a complete list of types... a huge list
53 of types.
54
55 %description -n perl-MojoX-MIME-Types -l pl.UTF-8
56 Ten moduł to zamiennik Mojolicious::Types, ale z bardziej poprawną
57 obsługą oraz pełną listą typów... bardzo dużą listą typów.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/MIME/*.pod
76 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/MojoX/MIME/Types.pod
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc ChangeLog README
84 %{perl_vendorlib}/MIME/Type.pm
85 %{perl_vendorlib}/MIME/Types.pm
86 %{perl_vendorlib}/MIME/types.db
87 %{_mandir}/man3/MIME::Type.3pm*
88 %{_mandir}/man3/MIME::Types.3pm*
89
90 %files -n perl-MojoX-MIME-Types
91 %defattr(644,root,root,755)
92 %dir %{perl_vendorlib}/MojoX/MIME
93 %{perl_vendorlib}/MojoX/MIME/Types.pm
94 %{_mandir}/man3/MojoX::MIME::Types.3pm*
This page took 0.049294 seconds and 3 git commands to generate.