]> git.pld-linux.org Git - packages/perl-Log-LogLite.git/blob - perl-Log-LogLite.spec
7ee1ba406bfaf0eb1b74a73430b7f9c06c54438d
[packages/perl-Log-LogLite.git] / perl-Log-LogLite.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define pdir    Log
7 %define pnam    LogLite
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Log::LogLite - class to help us create simple logs for our application
10 Summary(pl.UTF-8):      Log::LogLite - klasa pomagająca tworzyć proste logi z aplikacji
11 Name:           perl-Log-LogLite
12 Version:        0.82
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  67e72da51df7423c028b4dc0186f5f52
19 URL:            http://search.cpan.org/dist/Log-LogLite/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl-IO-LockedFile
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 In order to have a log we have first to create a Log::LogLite object.
30 The Log::LogLite object is created with a logging level. The default
31 logging level is 5. After the Log::LogLite object is created, each
32 call to the write method may write a new line in the log file. If the
33 level of the message is lower or equal to the logging level, the
34 message will be written to the log file. The format of the logging
35 messages can be controled by changing the template, and by defining a
36 default message. The class uses the IO::LockedFile class.
37
38 %description -l pl.UTF-8
39 W celu stworzenia logu trzeba najpierw utworzyć obiekt Log::LogLite.
40 Obiekt Log::LogLite tworzy się z poziomem logowania. Domyślny poziom
41 logowania to 5. Po utworzeniu obiektu Log::LogLite każde wywołanie
42 metody write może zapisać nową linię w pliku logu. Jeśli poziom
43 komunikatu jest mniejszy lub równy poziomowi logowania, komunikat jest
44 zapisywany do pliku. Format komunikatów logujących może być sterowany
45 poprzez zmianę szablonu i definiowanie domyślnego komunikatu. Ta klasa
46 używa klasy IO::LockedFile.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Log/*.pm
71 %{_mandir}/man3/*
This page took 0.067993 seconds and 2 git commands to generate.