]> git.pld-linux.org Git - packages/perl-Log-Log4perl.git/blob - perl-Log-Log4perl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Log-Log4perl.git] / perl-Log-Log4perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Log
6 %define         pnam    Log4perl
7 Summary:        Log::Log4perl Perl module - adds logging capabilities
8 Summary(pl.UTF-8):      Moduł Perla Log::Log4perl - dostarczenie obsługi logowania
9 Name:           perl-Log-Log4perl
10 Version:        1.46
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d247d2327d7f32dca09cbeb51a953fc5
17 URL:            http://mschilli.github.io/log4perl/
18 %if %{with tests}
19 BuildRequires:  perl(File::Path) >= 2.06_06
20 BuildRequires:  perl(File::Spec) >= 0.82
21 BuildRequires:  perl-DBD-CSV >= 0.33
22 BuildRequires:  perl-DBD-SQLite
23 BuildRequires:  perl-DBI >= 1.607
24 BuildRequires:  perl-Log-Dispatch
25 #BuildRequires: perl-Log-Dispatch-FileRotate >= 1.10
26 BuildRequires:  perl-SQL-Statement >= 1.20
27 BuildRequires:  perl-Test-Simple >= 0.45
28 BuildRequires:  perl-XML-DOM >= 1.43
29 #BuildRequires: perl-rrdtool
30 %endif
31 BuildRequires:  perl-devel >= 1:5.8.0
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  rpmbuild(macros) >= 1.663
34 Requires:       perl-XML-DOM >= 1.43
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # used conditionally
39 %define         _noautoreq_perl XML::DOM LWP::UserAgent Log::Dispatch::FileRotate Log::Log4Perl.* RRDs
40
41 %description
42 Log::Log4perl lets you remote-control and fine-tune the logging
43 behaviour of your system from the outside. It implements the widely
44 popular (Java-based) Log4j logging package in pure Perl.
45
46 %description -l pl.UTF-8
47 Log::Log4perl pozwala na zdalne sterowanie i szczegółowe dostosowanie
48 sposobu logowania z zewnątrz. Jest implementacją popularnego (opartego
49 na Javie) pakietu logującego Log4j w czystym Perlu.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL < /dev/null \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes LICENSE
73 %attr(755,root,root) %{_bindir}/l4p-tmpl
74 %{perl_vendorlib}/Log/Log4perl.pm
75 %{perl_vendorlib}/Log/Log4perl
76 %{_mandir}/man1/l4p-tmpl.1p*
77 %{_mandir}/man3/Log::Log4perl*.3pm*
This page took 0.136304 seconds and 3 git commands to generate.