]> git.pld-linux.org Git - packages/perl-Log-Fu.git/blob - perl-Log-Fu.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Log-Fu.git] / perl-Log-Fu.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Log
6 %define         pnam    Fu
7 Summary:        Log::Fu - Simplified and developer-friendly screen logging
8 Summary(pl.UTF-8):      Log::Fu - uproszczone i przyjazne dla programistów logowanie na ekranie
9 Name:           perl-Log-Fu
10 Version:        0.31
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Log/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  28354f432e52e5d9b4553259da920068
17 URL:            http://search.cpan.org/dist/Log-Fu/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Constant-Generate >= 0.04
22 BuildRequires:  perl-Dir-Self
23 BuildRequires:  perl-Test-Simple
24 %endif
25 Requires:       perl-Constant-Generate >= 0.04
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a simple interface for console logging. It provides a few
31 functions, log_info, log_debug, log_warn, log_crit, and log_err. They
32 all take strings as arguments, and can take as many arguments as you
33 so desire (so any concatenation is done for you).
34
35 A message is printed to standard error (or to $target if specified),
36 prefixed with the filename, line number, and originating subroutine of
37 the message.
38
39 %description -l pl.UTF-8
40 Ten moduł to prosty interfejs do logowania na konsoli. Udostępnia
41 kilka funkcji: log_info, log_debug, log_warn, log_crit i log_err.
42 Wszystkie jako argumenty przyjmują łańcuchy w dowolnej liczbie
43 (łączenie ich jest wykonywane za programistę).
44
45 Komunikat jest wypisywany na standardowe wyjście diagnostyczne (lub
46 $target, jeśli został podany) i jest poprzedzany nazwą pliku, numerem
47 linii i procedurą, z której pochodzi komunikat.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/Log/Fu.pm
72 %{perl_vendorlib}/Log/Fu
73 %{_mandir}/man3/Log::Fu.3pm*
This page took 0.111913 seconds and 4 git commands to generate.