]> git.pld-linux.org Git - packages/perl-Locale-Codes.git/blob - perl-Locale-Codes.spec
- updated to 3.63
[packages/perl-Locale-Codes.git] / perl-Locale-Codes.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         pdir    Locale
6 %define         pnam    Codes
7 Summary:        Locale::Codes - a distribution of modules to handle locale codes
8 Summary(pl.UTF-8):      Locale::Codes - zbiór modułów do obsługi kodów lokalizacji
9 Name:           perl-Locale-Codes
10 Version:        3.63
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Locale/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5c8e19b1157c28877de3bab6b99ee06b
17 URL:            https://metacpan.org/release/Locale-Codes
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-File-Find-Rule
24 BuildRequires:  perl-Test-Inter >= 1.09
25 BuildRequires:  perl-Test-Pod
26 BuildRequires:  perl-Test-Pod-Coverage
27 BuildRequires:  perl-Test-Simple
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Locale::Codes contains five modules which can be used to process ISO
34 codes for identifying country, currency, language and script.
35
36 %description -l pl.UTF-8
37 Locale::Codes zawiera pięć modułów umożliwiających przetwarzanie
38 kodów ISO identyfikujących kraj, walutę, język i pismo.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Locale/*.pod
57 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Locale/Codes/*.pod
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes LICENSE README.first
65 %{perl_vendorlib}/Locale/Codes.pm
66 %dir %{perl_vendorlib}/Locale/Codes
67 %{perl_vendorlib}/Locale/Codes/*.pm
68 %{perl_vendorlib}/Locale/Country.pm
69 %{perl_vendorlib}/Locale/Currency.pm
70 %{perl_vendorlib}/Locale/Language.pm
71 %{perl_vendorlib}/Locale/Script.pm
72 %{_mandir}/man3/Locale::Codes*.3pm*
73 %{_mandir}/man3/Locale::Country.3pm*
74 %{_mandir}/man3/Locale::Currency.3pm*
75 %{_mandir}/man3/Locale::Language.3pm*
76 %{_mandir}/man3/Locale::Script.3pm*
This page took 0.096654 seconds and 4 git commands to generate.