]> git.pld-linux.org Git - packages/perl-List-UtilsBy.git/blob - perl-List-UtilsBy.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-List-UtilsBy.git] / perl-List-UtilsBy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    List
6 %define         pnam    UtilsBy
7 Summary:        List::UtilsBy - higher-order list utility functions
8 Summary(pl.UTF-8):      List::UtilsBy - funkcje narzędziowe do list wyższego poziomu
9 Name:           perl-List-UtilsBy
10 Version:        0.11
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  14469e1029060490bc3a563f0e59e5f1
17 URL:            http://search.cpan.org/dist/List-UtilsBy/
18 BuildRequires:  perl-Module-Build >= 0.4004
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Exporter) >= 5.57
23 BuildRequires:  perl-Test-Simple >= 0.88
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides a number of list utility functions, all of which
30 take an initial code block to control their behaviour. They are
31 variations on similar core Perl or List::Util functions of similar
32 names, but which use the block to control their behaviour. For
33 example, the core Perl function sort takes a list of values and
34 returns them, sorted into order by their string value. The sort_by
35 function sorts them according to the string value returned by the
36 extra function, when given each value.
37
38 %description -l pl.UTF-8
39 Ten moduł udostępnia sporo funkcji narzędziowych do list,
40 przyjmujących początkowy blok kodu sterujący ich zachowaniem. Są to
41 warianty podobnych funkcji podstawowych Perla lub List::Util o
42 podobnych nazwach, ale wykorzystujące blok do sterowania zachowaniem.
43 Na przykład, funkcja podstawowa Perla sort przyjmuje listę wartości i
44 je zwraca w kolejności posortowanej według wartości jako łańcuchów.
45 Funkcja sort_by sortuje wartości według wartości łańcucha zwracanej
46 przez dodatkową funkcję, której przekazywana jest każda wartość.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Build.PL \
53         destdir=$RPM_BUILD_ROOT \
54         installdirs=vendor
55 ./Build
56
57 %{?with_tests:./Build test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 ./Build install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/List/UtilsBy.pm
71 %{_mandir}/man3/List::UtilsBy.3pm*
This page took 0.074427 seconds and 4 git commands to generate.