]> git.pld-linux.org Git - packages/perl-Linux-Pid.git/blob - perl-Linux-Pid.spec
perl 5.38.0 rebuild
[packages/perl-Linux-Pid.git] / perl-Linux-Pid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Linux
6 %define         pnam    Pid
7 Summary:        Linux::Pid - get the native PID and the PPID on Linux
8 Summary(pl.UTF-8):      Linux::Pid - uzyskiwanie natywnych PID i PPID pod Linuksem
9 Name:           perl-Linux-Pid
10 Version:        0.04
11 Release:        19
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Linux/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  130c4d299f827abf1f2285fddf03fccb
17 URL:            http://search.cpan.org/dist/Linux-Pid/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Inline-C
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Linux::Pid gets the native PID and the PPID on Linux. It's useful with
27 multithreaded programs. Linux's C library returns different values of
28 the PID and the PPID from different threads. This module forces Perl
29 to call the underlying C functions getpid() and getppid().
30
31 %description -l pl.UTF-8
32 Linux::Pid odczytuje natywne PID i PPID pod Linuksem. Jest przydatny w
33 programach wielowątkowych. Linuksowa biblioteka C zwraca różne
34 wartości PID i PPID dla różnych wątków. Ten moduł zmusza Perla do
35 wywołania funkcji C getpid() i getppid().
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{perl_vendorarch}/%{pdir}/*.pm
59 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
60 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
61 %{_mandir}/man3/*
This page took 0.081629 seconds and 4 git commands to generate.