]> git.pld-linux.org Git - packages/perl-Linux-Inotify2.git/blob - perl-Linux-Inotify2.spec
perl 5.38.0 rebuild
[packages/perl-Linux-Inotify2.git] / perl-Linux-Inotify2.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %define pdir    Linux
6 %define pnam    Inotify2
7 Summary:        Linux::Inotify2 - scalable directory/file change notification
8 #Summary(pl.UTF-8):
9 Name:           perl-Linux-Inotify2
10 Version:        2.3
11 Release:        3
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        https://www.cpan.org/modules/by-module/Linux/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2ef33c2f80104c6187a950fb7d3075fe
16 URL:            https://search.cpan.org/dist/Linux-Inotify2/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-common-sense
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements an interface to the Linux 2.6.13 and later
24 Inotify file/directory change notification sytem.
25
26 It has a number of advantages over the Linux::Inotify module:
27
28    - it is portable (Linux::Inotify only works on x86)
29    - the equivalent of fullname works correctly
30    - it is better documented
31    - it has callback-style interface, which is better suited for
32      integration.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorarch}/Linux
62 %{perl_vendorarch}/Linux/*.pm
63 %dir %{perl_vendorarch}/auto/Linux
64 %dir %{perl_vendorarch}/auto/Linux/Inotify2
65 %attr(755,root,root) %{perl_vendorarch}/auto/Linux/Inotify2/*.so
66 %{_mandir}/man3/*
67 %{_examplesdir}/%{name}-%{version}
This page took 0.233653 seconds and 4 git commands to generate.