]> git.pld-linux.org Git - packages/perl-JavaScript-Minifier.git/commitdiff
- added auto/th/perl-JavaScript-Minifier-1_05-1
authoraredridel <aredridel@pld-linux.org>
Wed, 11 May 2011 02:01:04 +0000 (02:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-JavaScript-Minifier.spec -> 1.1

perl-JavaScript-Minifier.spec [new file with mode: 0644]

diff --git a/perl-JavaScript-Minifier.spec b/perl-JavaScript-Minifier.spec
new file mode 100644 (file)
index 0000000..7627815
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+#
+%define                pdir    JavaScript
+%define                pnam    Minifier
+%include       /usr/lib/rpm/macros.perl
+Summary:       JavaScript::Minifier - Perl extension for minifying JavaScript code
+#Summary(pl.UTF-8):    
+Name:          perl-JavaScript-Minifier
+Version:       1.05
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/JavaScript/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 14c1fa2fcf76c97de4d0fe0d8d7fc145
+# generic URL, check or change before uncommenting
+#URL:          http://search.cpan.org/dist/JavaScript-Minifier/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module removes unnecessary whitespace from JavaScript code. The primary requirement developing this module is to not break working code: if working JavaScript is in input then working JavaScript is output. It is ok if the input has missing semi-colons, snips like '++ +' or '12 .toString()', for example. Internet Explorer conditional comments are copied to the output but the code inside these comments will not be minified.
+
+The ECMAScript specifications allow for many different whitespace characters: space, horizontal tab, vertical tab, new line, carriage return, form feed, and paragraph separator. This module understands all of these as whitespace except for vertical tab and paragraph separator. These two types of whitespace are not minimized.
+
+For static JavaScript files, it is recommended that you minify during the build stage of web deployment. If you minify on-the-fly then it might be a good idea to cache the minified file. Minifying static files on-the-fly repeatedly is wasteful.
+
+
+
+
+# %description -l pl.UTF-8
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorlib}/JavaScript/*.pm
+%{_mandir}/man3/*
This page took 0.094084 seconds and 4 git commands to generate.