]> git.pld-linux.org Git - packages/perl-JSON.git/blob - perl-JSON.spec
- pl
[packages/perl-JSON.git] / perl-JSON.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    JSON
7 Summary:        JSON - parse and convert to JSON (JavaScript Object Notation)
8 Summary(pl.UTF-8):      JSON - analiza i konwersja do notacji JSON (JavaScript Object Notation)
9 Name:           perl-JSON
10 Version:        1.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MA/MAKAMAKA/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  c7b385e35f37b4c8595c4f6e7eeb573e
17 URL:            http://search.cpan.org/dist/JSON/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(HTTP::Request)
22 BuildRequires:  perl(HTTP::Response)
23 BuildRequires:  perl-libwww
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module converts between JSON (JavaScript Object Notation) and
30 Perl data structure into each other.
31
32 For JSON, See to <http://www.crockford.com/JSON/>.
33
34 %description -l pl.UTF-8
35 Ten moduł dokonuje konwersji między notacją JSON (JavaScript Object
36 Notation) a perlowymi strukturami danych.
37
38 Więcej informacji na temat notacji JSON można znaleźć pod adresem
39 <http://www.crockford.com/JSON/>.
40
41 %prep
42 %setup -q -n %{pdir}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/*.pm
64 %{perl_vendorlib}/Apache/*.pm
65 %{perl_vendorlib}/JSON
66 %{perl_vendorlib}/JSONRPC
67 %{_mandir}/man3/*
This page took 0.065283 seconds and 4 git commands to generate.