]> git.pld-linux.org Git - packages/perl-JSON-XS.git/blob - perl-JSON-XS.spec
- add CC to %{__make}
[packages/perl-JSON-XS.git] / perl-JSON-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    JSON
7 %define pnam    XS
8 Summary:        JSON::XS - JSON serialising/deserialising, done correctly and fast
9 Summary(pl.UTF-8):      JSON::JS - serializacja/deserializacja JSON wykonana poprawnie i szybko
10 Name:           perl-JSON-XS
11 Version:        1.22
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8038987c89f5ffa183283f37136cb521
18 URL:            http://search.cpan.org/dist/JSON-XS/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module converts Perl data structures to JSON and vice versa. Its
25 primary goal is to be correct and its secondary goal is to be
26 fast. To reach the latter goal it was written in C.
27
28 As this is the n-th-something JSON module on CPAN, what was the reason
29 to write yet another JSON module? While it seems there are many JSON
30 modules, none of them correctly handle all corner cases, and in most
31 cases their maintainers are unresponsive, gone missing, or not
32 listening to bug reports for other reasons.
33
34 %description -l pl.UTF-8
35 Ten moduł konwertuje struktury danych Perla do formatu JSON i
36 odwrotnie. Jego podstawowym celem jest poprawne działanie, a drugim -
37 szybkość. W celu osiągnięcia tego drugiego celu został napisany w C.
38
39 Jako że jest to już któryś moduł JSON w CPAN-ie, musiała istnieć jakaś
40 przyczyna dla napisania kolejnego modułu JSON. O ile istnieje wiele
41 takich modułów, żaden z nich nie obsługiwał wszystkich skrajnych
42 przypadków i w większości przypadków utrzymujący moduły nie
43 odpowiadali, zaginęli lub z innych powodów nie zwracali uwagi na
44 zgłoszenia błędów.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %{perl_vendorarch}/JSON/*.pm
74 %dir %{perl_vendorarch}/auto/JSON/XS
75 %{perl_vendorarch}/auto/JSON/XS/*.bs
76 %attr(755,root,root) %{perl_vendorarch}/auto/JSON/XS/*.so
77 %{_mandir}/man3/*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.126857 seconds and 3 git commands to generate.