]> git.pld-linux.org Git - packages/perl-JSON-Any.git/blob - perl-JSON-Any.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-JSON-Any.git] / perl-JSON-Any.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    JSON
6 %define pnam    Any
7 Summary:        JSON::Any - Wrapper Class for the various JSON classes.
8 #Summary(pl.UTF-8):     
9 Name:           perl-JSON-Any
10 Version:        1.29
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/JSON/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f7eea523d532668555456e4153334342
17 URL:            http://search.cpan.org/dist/JSON-Any/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-JSON >= 2.02
22 BuildRequires:  perl-JSON-XS
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module will provide a coherent API to bring together the various
29 JSON modules currently on CPAN.
30
31 # %description -l pl.UTF-8
32 # TODO
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} -MExtUtils::MakeMaker -we 'WriteMakefile(NAME=>"%{pdir}::%{pnam}")' \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/JSON/*.pm
57 %{_mandir}/man3/*
This page took 0.088711 seconds and 4 git commands to generate.