]> git.pld-linux.org Git - packages/perl-JE.git/blob - perl-JE.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-JE.git] / perl-JE.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    JE
6 Summary:        JE - Pure-Perl ECMAScript (JavaScript) Engine
7 Name:           perl-JE
8 Version:        0.058
9 Release:        1
10 # same as perl
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/JE/%{pdir}-%{version}.tar.gz
14 # Source0-md5:  2e78436792d8c7b07e83b738cbd76173
15 URL:            http://search.cpan.org/dist/JE/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-Tie-RefHash-Weak
20 BuildRequires:  perl-TimeDate
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 JE, short for JavaScript::Engine (imaginative, isn't it?), is a
27 pure-Perl JavaScript engine.
28
29 %prep
30 %setup -q -n %{pdir}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} pure_install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changes README
50 %{perl_vendorlib}/JE.pm
51 %{perl_vendorlib}/JE
52 %{perl_vendorlib}/JavaScript/Engine.pm
53 %{_mandir}/man3/JE.3pm*
54 %{_mandir}/man3/JE::*.3pm*
55 %{_mandir}/man3/JavaScript::Engine.3pm*
This page took 0.05704 seconds and 4 git commands to generate.