]> git.pld-linux.org Git - packages/perl-Inline.git/blob - perl-Inline.spec
079e59653d1e1468d33d6a080ee8a975f3665036
[packages/perl-Inline.git] / perl-Inline.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Inline
3 Summary:        Inline Perl module - write Perl subroutines in other programming languages
4 Summary(pl.UTF-8):      Moduł Perla Inline - tworzenie funkcji perlowych w innych językach programowania
5 Name:           perl-Inline
6 Version:        0.80
7 Release:        1
8 Epoch:          1
9 # same as perl
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/Inline/%{pdir}-%{version}.tar.gz
13 # Source0-md5:  510bbac46e727bcaf240b7feac2646c9
14 URL:            http://search.cpan.org/dist/Inline/
15 BuildRequires:  perl-devel >= 1:5.8.1
16 BuildRequires:  perl(File::Spec) >= 0.8
17 BuildRequires:  perl-Digest-MD5 >= 2.09
18 BuildRequires:  perl-Parse-RecDescent >= 1.80
19 BuildRequires:  perl-Test-Simple >= 0.88
20 BuildRequires:  perl-Test-Warn >= 0.23
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Inline module allows you to put source code from other programming
27 languages directly "inline" in a Perl script or module. The code is
28 automatically compiled as needed, and then loaded for immediate access
29 from Perl.
30
31 %description -l pl.UTF-8
32 Moduł Inline pozwala umieszczać kod źródłowy w innych językach
33 programowania bezpośrednio wewnątrz skryptu lub modułu perlowego. Kod
34 jest w razie potrzeby automatycznie kompilowany, a następnie ładowany
35 w celu bezpośredniego dostępu z poziomu Perla.
36
37 %prep
38 %setup -q -n %{pdir}-%{version}
39
40 %{__mv} lib/Inline/MakeMaker/Changes Changes.Inline_MakeMaker
41
42 %build
43 echo "y" | perl Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod \
54         $RPM_BUILD_ROOT%{perl_vendorlib}/Inline/*.pod
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes Changes.Inline_MakeMaker README
62 %{perl_vendorlib}/Inline.pm
63 %{perl_vendorlib}/Inline/denter.pm
64 %{perl_vendorlib}/Inline/Foo.pm
65 %{perl_vendorlib}/Inline/MakeMaker.pm
66 %{_mandir}/man3/Inline.3pm*
67 %{_mandir}/man3/Inline::API.3pm*
68 %{_mandir}/man3/Inline::FAQ.3pm*
69 %{_mandir}/man3/Inline::Support.3pm*
This page took 0.039813 seconds and 2 git commands to generate.