]> git.pld-linux.org Git - packages/perl-Importer.git/blob - perl-Importer.spec
- initial
[packages/perl-Importer.git] / perl-Importer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Importer
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Importer - Alternative but compatible interface to modules that export symbols
8 Name:           perl-Importer
9 Version:        0.024
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/E/EX/EXODIST/Importer-%{version}.tar.gz
15 # Source0-md5:  2d29c79e65e221105a23e28c239b688f
16 URL:            http://search.cpan.org/dist/Importer/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module acts as a layer between Exporter and modules which consume
26 exports. It is feature-compatible with Exporter, plus some much needed
27 extras. You can use this to import symbols from any exporter that
28 follows Exporters specification. The exporter modules themselves do
29 not need to use or inherit from the Exporter module, they just need to
30 set @EXPORT and/or other variables.
31
32 %prep
33 %setup -q -n %{pdir}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorlib}/Importer.pm
55 %{_mandir}/man3/Importer.3pm*
This page took 0.083364 seconds and 4 git commands to generate.