]> git.pld-linux.org Git - packages/perl-IPC-SharedCache.git/blob - perl-IPC-SharedCache.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IPC-SharedCache.git] / perl-IPC-SharedCache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IPC
6 %define         pnam    SharedCache
7 Summary:        IPC::SharedCache - manage a cache in SysV IPC shared memory
8 Summary(pl.UTF-8):      IPC::SharedCache - zarządzanie pamięcią podręczną w pamięci dzielonej SysV
9 Name:           perl-IPC-SharedCache
10 Version:        1.3
11 Release:        8
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IPC/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  4d5d159a6b41d42918b7c1fceafb43ae
16 Patch0:         %{name}-wrap-IPC-ShareLite-new-calls-inside-eval-block.patch
17 URL:            http://search.cpan.org/dist/IPC-SharedCache/
18 BuildRequires:  perl-Carp-Assert
19 BuildRequires:  perl-IPC-ShareLite >= 0.06
20 BuildRequires:  perl-IPC-SysV
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a shared memory cache accessed as a tied hash.
28
29 %description -l pl.UTF-8
30 Ten moduł udostępnia cache pamięci dzielonej, dostępny jako dowiązany
31 hash.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35 %patch0 -p1
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes ANNOUNCE
56 %{perl_vendorlib}/IPC/SharedCache.pm
57 %{_mandir}/man3/IPC::SharedCache.3pm*
This page took 0.033446 seconds and 3 git commands to generate.