]> git.pld-linux.org Git - packages/perl-IPC-Shareable.git/blob - perl-IPC-Shareable.spec
a6d37e226e9e8200001c39c09ea22cff35f8c59a
[packages/perl-IPC-Shareable.git] / perl-IPC-Shareable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %define         pdir    IPC
6 %define         pnam    Shareable
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        IPC::Shareable - share Perl variables between processes
9 Summary(pl.UTF-8):      IPC::Shareable - współdzielenie zmiennych Perla między procesami
10 Name:           perl-IPC-Shareable
11 Version:        0.60
12 Release:        6
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  51462dabfb4eec81e0b3417a9f9add4e
17 URL:            http://search.cpan.org/dist/IPC-Shareable/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IPC::Shareable allows you to tie a variable to shared memory making it
25 easy to share the contents of that variable with other Perl processes.
26 Scalars, arrays, and hashes can be tied. The variable being tied may
27 contain arbitrarily complex data structures - including references to
28 arrays, hashes of hashes, etc.
29
30 %description -l pl.UTF-8
31 Moduł IPC::Shareable pozwala związać zmienną z pamięcią dzieloną, co
32 ułatwia współdzielenie zawartości tej zmiennej z innymi procesami
33 Perla. Wiązane mogą być skalary, tablice i hasze. Powiązana zmienna
34 może zawierać dowolnie skomplikowane struktury danych - włączenie z
35 referencjami do tablic, haszy haszy itd.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %{__perl} -pi -e 's/^(require 5.005)(03;)$/$1_$2/' ./lib/IPC/Shareable.pm
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES CREDITS DISCLAIMER README TO_DO
63 %{perl_vendorlib}/%{pdir}/*.pm
64 %{perl_vendorlib}/%{pdir}/%{pnam}
65 %{_examplesdir}/%{name}-%{version}
66 %{_mandir}/man3/*
This page took 0.070606 seconds and 2 git commands to generate.