]> git.pld-linux.org Git - packages/perl-IPC-ShareLite.git/blob - perl-IPC-ShareLite.spec
- rebuild with perl 5.26
[packages/perl-IPC-ShareLite.git] / perl-IPC-ShareLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IPC
7 %define         pnam    ShareLite
8 Summary:        IPC::ShareLite Perl module - light-weight interface to shared memory
9 Summary(pl.UTF-8):      Moduł Perla IPC::ShareLite - lekki interfejs do pamięci dzielonej
10 Name:           perl-IPC-ShareLite
11 Version:        0.17
12 Release:        11
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IPC/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  54c7aa08dc065b6c946c48491d33450d
18 URL:            http://search.cpan.org/dist/IPC-ShareLite/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IPC::ShareLite provides a simple interface to shared memory, allowing
25 data to be efficiently communicated between processes. Your operating
26 system must support SysV IPC (shared memory and semaphores) in order
27 to use this module.
28
29 %description -l pl.UTF-8
30 IPC::ShareLite udostępnia prosty interfejs do pamięci wspólnej,
31 umożliwiając wydajną wymianę danych pomiędzy procesami. Aby
32 korzystanie z tego modułu było możliwe, System operacyjny musi
33 wspierać SysV IPC (pamięć wspólna i semafory).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL </dev/null \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/IPC/ShareLite.pm
60 %dir %{perl_vendorarch}/auto/IPC/ShareLite
61 %{perl_vendorarch}/auto/IPC/ShareLite/autosplit.ix
62 %attr(755,root,root) %{perl_vendorarch}/auto/IPC/ShareLite/ShareLite.so
63 %{_mandir}/man3/*
This page took 0.111105 seconds and 3 git commands to generate.