]> git.pld-linux.org Git - packages/perl-IO-Pipely.git/blob - perl-IO-Pipely.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-Pipely.git] / perl-IO-Pipely.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    Pipely
7 Summary:        IO::Pipely - Portably create pipe() or pipe-like handles, one way or another.
8 Name:           perl-IO-Pipely
9 Version:        0.005
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  86781d3e2afe5f142f67ce1fed3b9ed9
16 URL:            https://metacpan.org/release/IO-Pipely/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Pipes are troublesome beasts because there are a few different,
26 incompatible ways to create them.  Not all platforms support all ways,
27 and some platforms may have hidden difficulties like incomplete or
28 buggy support.
29
30 IO::Pipely provides a couple functions to portably create one- and
31 two-way pipes and pipe-like socket pairs.  It acknowledges and works
32 around known platform issues so you don't have to.
33
34 On the other hand, it doesn't work around unknown issues, so please
35 report any problems early and often.
36
37 IO::Pipely currently understands pipe(), UNIX-domain socketpair() and
38 regular IPv4 localhost sockets.  This covers every platform tested so
39 far, but it's hardly complete.  Please help support other mechanisms,
40 such as INET-domain socketpair() and IPv6 localhost sockets.
41
42 IO::Pipely will use different kinds of pipes or sockets depending on
43 the operating system's capabilities and the number of directions
44 requested.  The autodetection may be overridden by specifying a
45 particular pipe type.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CHANGES README
69 %{perl_vendorlib}/IO/*.pm
70 %{_mandir}/man3/*
This page took 0.15236 seconds and 4 git commands to generate.