]> git.pld-linux.org Git - packages/perl-IO-Multiplex.git/commitdiff
- updated to 1.07
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Oct 2003 22:14:55 +0000 (22:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added udptest-linux26 patch (udp test failed on Linux 2.6 because sendto
  returns EDESTADDRREQ on 2.6, not ENOTCONN as before)

Changed files:
    perl-IO-Multiplex-udptest-linux26.patch -> 1.1
    perl-IO-Multiplex.spec -> 1.13

perl-IO-Multiplex-udptest-linux26.patch [new file with mode: 0644]
perl-IO-Multiplex.spec

diff --git a/perl-IO-Multiplex-udptest-linux26.patch b/perl-IO-Multiplex-udptest-linux26.patch
new file mode 100644 (file)
index 0000000..bb29179
--- /dev/null
@@ -0,0 +1,20 @@
+--- IO-Multiplex-1.07/t/200_udp.t.orig 2003-07-30 08:22:08.000000000 +0200
++++ IO-Multiplex-1.07/t/200_udp.t      2003-10-25 00:13:09.749379920 +0200
+@@ -18,7 +18,7 @@
+ use Test;
+ use IO::Socket;
+ use IO::Multiplex;
+-use POSIX qw(ENOTCONN);
++use POSIX qw(ENOTCONN EDESTADDRREQ);
+ $| = 1;
+ plan tests => 15;
+@@ -103,7 +103,7 @@
+     # when trying to send() a packet.
+     $! = 0;
+     print $fh $msg2;
+-    ok ($! == ENOTCONN) || warn "DEBUG: bang = [$!](".($!+0).")";
++    ok ($! == ENOTCONN || $! == EDESTADDRREQ) || warn "DEBUG: bang = [$!](".($!+0).")";
+     # Grab the real peer destination.
+     ok my $saddr = $mux->{_fhs}{$sock2}{udp_peer};
index e09ea14625e5d5dea6660587d0b688c6ed7d0001..cfef5ccf9735b27a3aaecc40020a4e8124c79d98 100644 (file)
@@ -8,13 +8,14 @@
 Summary:       IO::Multiplex - Manage IO on many file handles
 Summary(pl):   IO::Multiplex - zarz±dzanie operacjami we/wy na wielu uchwytach plików
 Name:          perl-IO-Multiplex
-Version:       1.04
-Release:       2
+Version:       1.07
+Release:       1
 License:       Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: d78ca0342ad65988288e3a2198ddbaee
-BuildRequires: perl-devel >= 5.6
+# Source0-md5: 77def312f282bb2ed0a9c68317853c6b
+Patch0:                %{name}-udptest-linux26.patch
+BuildRequires: perl-devel >= 5.8
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -36,6 +37,7 @@ nas
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
+%patch -p1
 
 %build
 %{__perl} Makefile.PL \
@@ -47,7 +49,8 @@ nas
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.08075 seconds and 4 git commands to generate.