]> git.pld-linux.org Git - packages/perl-IO-LockedFile.git/blob - perl-IO-LockedFile.spec
7435c562c9363a582df5daa7a1d4fade2fdbe0e1
[packages/perl-IO-LockedFile.git] / perl-IO-LockedFile.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    LockedFile
8 Summary:        IO::LockedFile - supply object methods for locking files
9 Summary(pl.UTF-8):      IO::LockedFile - metody obiektów do blokowania blików
10 Name:           perl-IO-LockedFile
11 Version:        0.23
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f447f67ac7c9f42d86d07ca7477cdec6
18 URL:            http://search.cpan.org/dist/IO-LockedFile/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 In its simplistic use, the IO::LockedFile class gives us the same
26 interface of the IO::File class with the unique difference that the
27 files we deal with are locked using the Flock mechanism (using the
28 flock function).
29
30 %description -l pl.UTF-8
31 W najprostszym zastosowaniu klasa IO::LockedFile udostępnia ten sam
32 interfejs, co klasa IO::File z jedyną różnicą polegającą na tym, że
33 pliki są blokowane przy użyciu mechanizmu Flock (przy użyciu funkcji
34 flock).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/IO/*.pm
59 %{perl_vendorlib}/IO/LockedFile
60 %{_mandir}/man3/*
This page took 0.326254 seconds and 2 git commands to generate.