]> git.pld-linux.org Git - packages/perl-IO-Compress-Lzf.git/blob - perl-IO-Compress-Lzf.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-Compress-Lzf.git] / perl-IO-Compress-Lzf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    IO
6 %define pnam    Compress-Lzf
7 Summary:        Modules to read/write lzf files/buffers
8 Summary(pl.UTF-8):      Moduły do odczytu/zapisu plików/buforów lzf
9 Name:           perl-IO-Compress-Lzf
10 Version:        2.074
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7db7efeb9d0566fe1259f4d9ecedbb51
17 URL:            http://search.cpan.org/dist/IO-Compress-Lzf/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 5.16
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Compress-LZF
23 BuildRequires:  perl-IO-Compress >= %{version}
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 IO::Compress::Lzf and IO::Uncompress::UnLzf modules provide a Perl
30 interface that allows reading and writing lzf compressed data from/to
31 files or buffer.
32
33 Note that although this module uses Compress::LZF for compression, it
34 uses a different file format. The lzf file format used here is the
35 same as the lzf command-line utility that ships with the lzf library.
36
37 %description -l pl.UTF-8
38 Moduły IO::Compress::Lzf i IO::Uncompress::UnLzf udostępniają perlowy
39 interfejs umożliwiający odczyt i zapis danych skompresowanych
40 algorytmem lzf z/do plików lub buforów.
41
42 Należy zauważyć, że choć ten moduł wykorzystuje do kompresji moduł
43 Compress::LZF, używa innego formatu plików. Używany tutaj format
44 plików jest taki sam jak narzędzia lzf uruchamianego z linii poleceń,
45 dostarczanego wraz z biblioteką lzf.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/IO/Compress/Adapter/Lzf.pm
70 %{perl_vendorlib}/IO/Compress/Lzf.pm
71 %{perl_vendorlib}/IO/Uncompress/Adapter/Lzf.pm
72 %{perl_vendorlib}/IO/Uncompress/UnLzf.pm
73 %{_mandir}/man3/IO::Compress::Lzf.3pm*
74 %{_mandir}/man3/IO::Uncompress::UnLzf.3pm*
This page took 0.118749 seconds and 4 git commands to generate.