]> git.pld-linux.org Git - packages/perl-IO-All.git/blob - perl-IO-All.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-All.git] / perl-IO-All.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    All
7 Summary:        IO::All of it to Graham and Damian
8 Summary(pl.UTF-8):      IO::All - wszystkie IO dla Grahama i Damiana
9 Name:           perl-IO-All
10 Version:        0.86
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b257d3f742867825d018e74f5a5d549b
17 URL:            http://search.cpan.org/dist/IO-All/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-File-ReadBackwards
22 BuildRequires:  perl-IO-String
23 BuildRequires:  perl-MLDBM
24 BuildRequires:  perl-Spiffy >= 0.19
25 %endif
26 Requires:       perl-mixin
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 IO::All combines all of the best Perl IO modules into a single Spiffy
32 object oriented interface to greatly simplify your everyday Perl IO
33 idioms. It exports a single function called io, which returns a new
34 IO::All object. And that object can do it all!
35
36 The IO::All object is a proxy for IO::File, IO::Dir, IO::Socket,
37 IO::String, Tie::File and File::ReadBackwards. You can use most of the
38 methods found in these classes and in IO::Handle (which they all
39 inherit from). IO::All is easily subclassable. You can override any
40 methods and also add new methods of your own.
41
42 %description -l pl.UTF-8
43 IO::All łączy wszystkie najlepsze moduły Perla IO w pojedynczy
44 zorientowany obiektowo interfejs Spiffy, aby znacznie uprościć
45 codziennie używane idiomy IO. Eksportuje pojedynczą funkcję o nazwie
46 io, która zwraca nowy obiekt IO::All - i ten obiekt może robić to
47 wszystko!
48
49 Obiekt IO::All to proxy dla IO::File, IO::Dir, IO::Socket, IO::String,
50 Tie::File i File::ReadBackwards. Można używać większości z metod
51 obecnych w tych klasach oraz w IO::Handle (z którego one wszystkie
52 dziedziczą). IO::All może być łatwo użyty jako podklasa. Można
53 przykryć dowolne metody i dodać nowe, własne.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/All.pod
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %{perl_vendorlib}/IO/All.pm
80 %{perl_vendorlib}/IO/All
81 %{_mandir}/man3/IO::All*.3pm*
This page took 0.074435 seconds and 4 git commands to generate.