]> git.pld-linux.org Git - packages/perl-Hash-MultiValue.git/blob - perl-Hash-MultiValue.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Hash-MultiValue.git] / perl-Hash-MultiValue.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Hash
6 %define         pnam    MultiValue
7 Summary:        Hash::MultiValue - Store multiple values per key
8 Name:           perl-Hash-MultiValue
9 Version:        0.16
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Hash/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  508015312eb08cd2bcea987c4efbb93d
16 URL:            http://search.cpan.org/dist/Hash-MultiValue/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Hash::MultiValue is an object (and a plain hash reference) that may
24 contain multiple values per key, inspired by MultiDict of WebOb.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32 %{__make}
33
34 %{?with_tests:%{__make} test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %{__make} pure_install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc Changes README
48 %{perl_vendorlib}/Hash/*.pm
49 %{_mandir}/man3/*
This page took 0.117584 seconds and 4 git commands to generate.