]> git.pld-linux.org Git - packages/perl-HTTP-Tiny.git/blob - perl-HTTP-Tiny.spec
- new
[packages/perl-HTTP-Tiny.git] / perl-HTTP-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    HTTP
6 %define         pnam    Tiny
7 Summary:        HTTP::Tiny - A small, simple, correct HTTP/1.1 client
8 Summary(pl.UTF-8):      HTTP::Tiny - mały, prosty, poprawny klient HTTP/1.1
9 Name:           perl-HTTP-Tiny
10 Version:        0.076
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  752d43443c6cf9254b23b281a753120b
17 URL:            https://metacpan.org/release/HTTP-Tiny
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Test-Simple >= 0.96
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a very simple HTTP/1.1 client, designed for doing simple
31 requests without the overhead of a large framework like
32 LWP::UserAgent.
33
34 It is more correct and more complete than HTTP::Lite. It supports
35 proxies and redirection. It also correctly resumes after EINTR.
36
37 If IO::Socket::IP 0.25 or later is installed, HTTP::Tiny will use it
38 instead of IO::Socket::INET for transparent support for both IPv4 and
39 IPv6.
40
41 Cookie support requires HTTP::CookieJar or an equivalent class.
42
43 %description -l pl.UTF-8
44 Ten moduł to bardzo prosty klient HTTP/1.1, zaprojektowany do
45 wykonywania prostych żądań bez narzutu całego szkieletu, takiego jak
46 LWP::UserAgent.
47
48 Jest bardziej poprawny i kompletni niż HTTP::Lite. Obsługuje proxy i
49 przekierowania. Poprawnie też wznawia po EINTR.
50
51 Jeśli zainstalowany jest IO::Socket::IP w wersji 0.25 lub nowszej,
52 HTTP::Tiny używa go zamiast IO::Socket::INET w celu przezroczystej
53 obsługi zarówno IPv4, jak i IPv6.
54
55 Obsługa ciasteczek wymaga HTTP::CookieJar lub równoważnej klasy.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} pure_install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes
82 %{perl_vendorlib}/HTTP/Tiny.pm
83 %{_mandir}/man3/HTTP::Tiny.3pm*
84 %{_examplesdir}/%{name}-%{version}
This page took 0.162737 seconds and 4 git commands to generate.