]> git.pld-linux.org Git - packages/perl-HTML-Template.git/blob - perl-HTML-Template.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTML-Template.git] / perl-HTML-Template.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    Template
7 Summary:        HTML::Template - Perl module to use HTML templates from CGI scripts
8 Summary(pl.UTF-8):      HTML::Template - moduł Perla do obsługi szablonów HTML w skryptach CGI
9 Name:           perl-HTML-Template
10 Version:        2.97
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ee5f4a78102d2ffe089e047d2dbb0ff8
16 URL:            https://github.com/mpeters/html-template/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(File::Spec) >= 0.82
22 BuildRequires:  perl-Digest-MD5
23 BuildRequires:  perl-IPC-SharedCache
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module attempts make using HTML templates simple and natural.
30
31 It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
32 <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>. The file
33 written with HTML and these new tags is called a template. It is
34 usually saved separate from your script - possibly even created by
35 someone else!
36
37 Using this module you fill in the values for the variables, loops and
38 branches declared in the template. This allows you to seperate design
39 - the HTML - from the data, which you generate in the Perl script.
40
41 %description -l pl.UTF-8
42 Ten moduł próbuje uczynić wykorzystywanie szablonów HTML prostym i
43 naturalnym.
44
45 Rozszerza standardowy HTML o kilka znaczników HTML-opodobnych:
46 <TMPL_VAR>, <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> oraz <TMPL_ELSE>.
47 Plik napisany w HTML-u z użyciem tych nowych znaczników nazywa się
48 szablonem. Zwykle jest oddzielony od skryptu - a nawet tworzony przez
49 kogoś innego.
50
51 Przy użyciu tego modułu wypełnia się wartościami zmienne, pętle oraz
52 warunki zadeklarowane w szablonie. Pozwala to oddzielić projekt (HTML)
53 od danych generowanych w skrypcie perlowym.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:TEST_SHARED_MEMORY=1 TEST_FILE_CACHE=1 %{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 # just docs
72 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/HTML/Template/FAQ.pm
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README templates scripts
80 %{perl_vendorlib}/HTML/Template.pm
81 %dir %{perl_vendorlib}/HTML/Template
82 %{_mandir}/man3/HTML::Template.3pm*
83 %{_mandir}/man3/HTML::Template::FAQ.3pm*
This page took 0.147863 seconds and 3 git commands to generate.