]> git.pld-linux.org Git - packages/perl-HTML-Element-Extended.git/blob - perl-HTML-Element-Extended.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTML-Element-Extended.git] / perl-HTML-Element-Extended.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    Element-Extended
7 Summary:        Package of several enhanced HTML::Element* classes
8 Summary(pl.UTF-8):      Pakiet z kilkoma rozszerzonymi klasami HTML::Element*
9 Name:           perl-HTML-Element-Extended
10 Version:        1.18
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  41ec9dcc7cefa03b204d0e8ca8e1c112
17 URL:            http://search.cpan.org/dist/HTML-Element-Extended/
18 %if %{with tests}
19 BuildRequires:  perl(Data::Dumper)
20 BuildRequires:  perl-HTML-Tree >= 3.01
21 BuildRequires:  perl(HTML::Element) >= 3.01
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 HTML-Element-Extended is a package of several enhanced HTML::Element
30 classes, most of which arose during the effort to implement an
31 HTML::Element based table class.
32
33 The modules are: HTML::ElementTable, HTML::ElementSuper,
34 HTML::ElementGlob, HTML::ElementRaw.
35
36 The resulting functionality enables: tables, element globs, element
37 coordinates, content replacement, content wrapping, element cloning,
38 raw HTML string adoption.
39
40 %description -l pl.UTF-8
41 HTML-Element-Extended to pakiet z kilkoma rozszerzonymi klasami
42 HTML::Element, z których większość powstała podczas próby
43 zaimplementowania klas opartych na HTML::Element.
44
45 Moduły składowe to: HTML::ElementTable, HTML::ElementSuper,
46 HTML::ElementGlob, HTML::ElementRaw.
47
48 Wynikowa funkcjonalność obejmuje: tabele, maski elementów, współrzędne
49 elementów, zmianę zawartości, zawijanie zawartości, klonowanie
50 elementów, adopcję surowych łańcuchów HTML.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorlib}/HTML/ElementGlob.pm
76 %{perl_vendorlib}/HTML/ElementRaw.pm
77 %{perl_vendorlib}/HTML/ElementSuper.pm
78 %{perl_vendorlib}/HTML/ElementTable.pm
79 %{_mandir}/man3/HTML::Element*.3pm*
This page took 0.081991 seconds and 4 git commands to generate.