]> git.pld-linux.org Git - packages/perl-Gnome2.git/blob - perl-Gnome2.spec
cfc4f39a4e9687674ac90906c50083561606d543
[packages/perl-Gnome2.git] / perl-Gnome2.spec
1 #
2 # Conditional build:
3 %bcond_with tests       # perform "make test" (requires X server)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pnam    Gnome2
7 Summary:        Perl interface to the 2.x series of the Gnome libraries
8 Summary(pl):    Perlowy interfejs do bibliotek GNOME 2.x
9 Name:           perl-%{pnam}
10 Version:        0.49
11 Release:        0.1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b80f07bd0a6b0c90fcafc1430cd737c1
16 URL:            http://gtk2-perl.sf.net/
17 BuildRequires:  gtk+2-devel
18 BuildRequires:  libgnomeui-devel >= 2.0.0
19 BuildRequires:  perl-ExtUtils-Depends >= 0.1
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.00
21 BuildRequires:  perl-Glib >= 1.013
22 BuildRequires:  perl-Gnome2-VFS >= 0.05
23 BuildRequires:  perl-Gtk2 >= 1.013
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Gnome2 Perl module allows a perl developer to use the GNOME 2
31 libraries.
32
33 %description -l pl
34 Modu³ Perla Gnome2 pozwala programistom perlowym na u¿ywanie bibliotek
35 ¶rodowiska GNOME 2.
36
37 %prep
38 %setup -q -n %{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make} \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/%{pnam}/{*,*/*}.pod
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS ChangeLog README TODO
63 %dir %{perl_vendorarch}/%{pnam}/Install
64 %attr(755,root,root) %{perl_vendorarch}/auto/%{pnam}/*.so
65 %{perl_vendorarch}/auto/%{pnam}/*.bs
66 %{perl_vendorarch}/%{pnam}/Install/*
67 %{perl_vendorarch}/%{pnam}.pm
68 %{_mandir}/man3/*
This page took 0.063395 seconds and 2 git commands to generate.