]> git.pld-linux.org Git - packages/perl-Gnome2.git/blob - perl-Gnome2.spec
9f527b00bf3383638178a7c857c0ae08fd33bc84
[packages/perl-Gnome2.git] / perl-Gnome2.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires X server)
4 #
5 %define         pdir    Gnome2
6 Summary:        Perl interface to the 2.x series of the GNOME libraries
7 Summary(pl.UTF-8):      Interfejs perlowy do bibliotek GNOME 2.x
8 Name:           perl-Gnome2
9 Version:        1.046
10 Release:        6
11 License:        LGPL v2.1+
12 Group:          Development/Languages/Perl
13 Source0:        http://download.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
14 # Source0-md5:  abb820a474237f6c8d6c2dc19ba3c1e6
15 URL:            http://gtk2-perl.sourceforge.net/
16 BuildRequires:  libbonoboui-devel >= 2.0.0
17 BuildRequires:  libgnomeui-devel >= 2.14.1
18 BuildRequires:  perl-ExtUtils-Depends >= 0.201
19 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
20 BuildRequires:  perl-Glib-devel >= 1.140
21 BuildRequires:  perl-Gnome2-Canvas-devel >= 1.002
22 BuildRequires:  perl-Gnome2-VFS-devel >= 1.060
23 BuildRequires:  perl-Gtk2-devel >= 1.140
24 BuildRequires:  perl-devel >= 1:5.8.0
25 %if %{with tests}
26 BuildRequires:  perl-Test-Number-Delta >= 1.0
27 %endif
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 Requires:       libbonoboui >= 2.0.0
30 Requires:       libgnomeui >= 2.14.1
31 Requires:       perl-Glib >= 1.140
32 Requires:       perl-Gnome2-Canvas >= 1.002
33 Requires:       perl-Gnome2-VFS >= 1.060
34 Requires:       perl-Gtk2 >= 1.140
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Gnome2 Perl module allows a Perl developer to use the GNOME 2
39 libraries.
40
41 %description -l pl.UTF-8
42 Moduł Perla Gnome2 pozwala programistom perlowym na używanie bibliotek
43 środowiska GNOME 2.
44
45 %package devel
46 Summary:        Development files for Perl Gnome2 bindings
47 Summary(pl.UTF-8):      Pliki programistyczne wiązań Gnome2 dla Perla
48 Group:          Development/Languages/Perl
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libbonoboui-devel >= 2.0.0
51 Requires:       libgnomeui-devel >= 2.14.1
52 Requires:       perl-Glib-devel >= 1.140
53 Requires:       perl-Gnome2-Canvas-devel >= 1.002
54 Requires:       perl-Gnome2-VFS-devel >= 1.060
55 Requires:       perl-Gtk2-devel >= 1.140
56
57 %description devel
58 Development files for Perl Gnome2 bindings.
59
60 %description devel -l pl.UTF-8
61 Pliki programistyczne wiązań Gnome2 dla Perla.
62
63 %prep
64 %setup -q -n %{pdir}-%{version}
65
66 %build
67 %{__perl} Makefile.PL \
68         INSTALLDIRS=vendor
69
70 %{__make} \
71         CC="%{__cc}" \
72         OPTIMIZE="%{rpmcflags}"
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/{*,*/*}.pod
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS README TODO
90 %{perl_vendorarch}/Gnome2.pm
91 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/Gnome2.so
92 %{_mandir}/man3/Gnome2.3pm*
93 %{_mandir}/man3/Gnome2::*.3pm*
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{perl_vendorarch}/Gnome2/Install
This page took 0.058735 seconds and 2 git commands to generate.