]> git.pld-linux.org Git - packages/perl-Gnome2.git/blob - perl-Gnome2.spec
3d80a36cacf7ea7da9496c906e5b88db7ae317b2
[packages/perl-Gnome2.git] / perl-Gnome2.spec
1 #
2 # Conditional build:
3 %bcond_with tests       # perform "make test" (requires X server)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pnam    Gnome2
7 Summary:        Perl interface to the 2.x series of the Gnome libraries
8 Summary(pl):    Perlowy interfejs do bibliotek GNOME 2.x
9 Name:           perl-%{pnam}
10 Version:        0.90
11 Release:        0.1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2e2219cc133afef04e6ac7b62ffacfc5
16 URL:            http://gtk2-perl.sf.net/
17 BuildRequires:  gtk+2-devel
18 BuildRequires:  libgnomeui-devel >= 2.0.0
19 BuildRequires:  perl-ExtUtils-Depends >= 0.1
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.00
21 BuildRequires:  perl-Glib >= 1.020
22 BuildRequires:  perl-Gnome2-VFS >= 0.10
23 BuildRequires:  perl-Gtk2 >= 1.021
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Gnome2 Perl module allows a perl developer to use the GNOME 2
30 libraries.
31
32 %description -l pl
33 Modu³ Perla Gnome2 pozwala programistom perlowym na u¿ywanie bibliotek
34 ¶rodowiska GNOME 2.
35
36 %prep
37 %setup -q -n %{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make} \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/%{pnam}/{*,*/*}.pod
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS ChangeLog README TODO
62 %dir %{perl_vendorarch}/%{pnam}/Install
63 %attr(755,root,root) %{perl_vendorarch}/auto/%{pnam}/*.so
64 %{perl_vendorarch}/auto/%{pnam}/*.bs
65 %{perl_vendorarch}/%{pnam}/Install/*
66 %{perl_vendorarch}/%{pnam}.pm
67 %{_mandir}/man3/*
This page took 0.043349 seconds and 2 git commands to generate.