]> git.pld-linux.org Git - packages/perl-Gnome2-Print.git/blob - perl-Gnome2-Print.spec
edebb5cc5326671abc2cd33fe003a6ae29055533
[packages/perl-Gnome2-Print.git] / perl-Gnome2-Print.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires X server)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pnam    Gnome2-Print
7 Summary:        Perl interface to the GNOME Print libraries
8 Summary(pl.UTF-8):      Interfejs perlowy do bibliotek GNOME Print
9 Name:           perl-Gnome2-Print
10 Version:        1.000
11 Release:        2
12 License:        LGPL
13 Group:          Development/Languages/Perl
14 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  66578c2ffaebbe035a0735e65ad71c3f
16 URL:            http://gtk2-perl.sourceforge.net/
17 BuildRequires:  libgnomeprintui-devel >= 2.2.0
18 BuildRequires:  perl-ExtUtils-Depends >= 0.1
19 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
20 BuildRequires:  perl-Glib >= 1.120
21 BuildRequires:  perl-Gtk2 >= 1.120
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       libgnomeprintui >= 2.2.0
26 Requires:       perl-Glib >= 1.120
27 Requires:       perl-Gtk2 >= 1.120
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Gnome2::Print Perl module allows a Perl developer to use the GNOME
32 Printing libraries with Gtk2-perl.
33
34 %description -l pl.UTF-8
35 Moduł Perla Gnome2::Print umożliwia programistom perlowym korzystanie
36 z bibliotek GNOME Print wraz z Gtk2-perl.
37
38 %prep
39 %setup -q -n %{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/Print/{,*/}*.pod
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS ChangeLog NEWS README
65 %{perl_vendorarch}/Gnome2/Print.pm
66 %dir %{perl_vendorarch}/Gnome2/Print
67 %{perl_vendorarch}/Gnome2/Print/Config
68 %{perl_vendorarch}/Gnome2/Print/Font
69 %{perl_vendorarch}/Gnome2/Print/Install
70 %dir %{perl_vendorarch}/auto/Gnome2/Print
71 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/Print/*.so
72 %{perl_vendorarch}/auto/Gnome2/Print/*.bs
73 %{_mandir}/man3/*
This page took 0.051286 seconds and 2 git commands to generate.